[Logo]
 
  [Search] Search   [Recent Topics] Recent Topics   [Members]  Member Listing   [Groups] Back to home page 
[Register] Register / 
[Login] Login 
Possible conflict with Monster Manager (?)  XML
Forum Index -> Other Mods
Author Message
Szappy



Joined: 07/16/2006 13:49:57
Messages: 4
Offline

Hello!

I'm asking for help in a possible conflict in my game, and ideas to overcome it. I'm using DruidsRPG, Monster Mover, and Monster Manager at the same time (among other things, but this particular problem is narrowed down to these three).

RPG for obvious reasons ;) Monster mover... also ;) and the MosterManager: for custom linksetups, and the very good monster randomizer (lets me have random sized/strength monsters, adds in quite a variety).
Oh, I have SMP and the U4E monsters too.

The problem: the game crashes after some time in invasion, with the following error:
Code:
UT2004 Build UT2004_Build_[2005-11-23_16.22]
 
 OS: Windows XP 5.1 (Build: 2600)
 CPU: AuthenticAMD PentiumPro-class processor @ 2082 MHz with 1023MB RAM
 Video: NVIDIA GeForce 6600 GT  (9131)
 
 RPGArtifactManager DM-DesertIsle.RPGArtifactManager (Function UT2004RPG.RPGArtifactManager.SpawnArtifact:0089)
 Runaway loop detected (over 10000000 iterations)
 
 History: FFrame::Serialize <- UObject::ProcessEvent <- (RPGArtifactManager DM-DesertIsle.RPGArtifactManager,
 Function UT2004RPG.RPGArtifactManager.Timer) <- AActor::Tick <- TickAllActors <- ULevel::Tick <- (NetMode=2)
 <- TickLevel <- UGameEngine::Tick <- Level DesertIsle <- UpdateWorld <- MainLoop <- FMallocWindows::Free
 <- FMallocWindows::Realloc <- 10910191 0 FArray <- FArray::Realloc <- 0*2 <- FMallocWindows::Free

It's always the "Function UT2004RPG.RPGArtifactManager.SpawnArtifact" that the RPG engine is trying to spawn an artifact, but is somehow unable to.

Here's what needs to be set, to produce this error (at least it always happens for me):
Have the abovementioned mutators turned on, have custom wave setups in monster manager, have RPG spawn artifacts.

What I tried so far, and my observations:
- the error seems accurate, since turning off artifacts in RPG does not cause the error
- not having monster mover in also doesn's spawn the crash
- the weirdest: having custom wavesetups off in monster manager also seems to 'solve' this

I don't want to turn off either artifacts (too good not to use) monster mover (hate having monsters spawn on my head, and also hunting for that last monster every round) and the manager (random monsters is great, and for waves... the default wave setting in UT2k4 lacks the nice features of the manager).
I even tried turning off custom waves in the manager, and using satore's wave configurator, but then I always ended up having waves that never ended, possibly due to miscounting remaining monsters. The manager has a solution for this, but seemingly it only works, if it's using its own wave configurator.

Maybe it just that I have set something wrongly in the ini files, or some other config error, but IMO it's somehow related to the monster mover defining the distance from the player, to spawn an artifact. But that is only a stab in the dark. Then again, satore's wavestups seem to work well, so it might be a Monster Manager bug.

Any solution/idea is appreciated, as to what might be causing this? If it's not related to RPG please point me to the right directions, where I should ask this?

Szappy
Moof

Wicked Sick!
[Avatar]
Joined: 06/24/2006 19:42:44
Messages: 433
Location: College Park, MD
Offline

If we can get this fixed, I'd so be for including this on DC.

I'll try to take a look in a few minutes here.

Moof, Scholar of Ni

Moof (W); Dr. Moof (M); Engimoof (E); Moofgineer (E beta)
[Yahoo!] aim icon [ICQ]
Moof

Wicked Sick!
[Avatar]
Joined: 06/24/2006 19:42:44
Messages: 433
Location: College Park, MD
Offline

After looking at what it does, I'm not really sure it would be appropriate for DC.

However!

There is a do..until loop at lines 129-148 of RPGArtifactManager.uc. Basically, it finds a monster it can give a new artifact to, and quits once it has done so. It appears that Monster Manager dynamically changes the number of monsters allocated for waves, and this could interfere with the finding process.

However, I'm not sure if I can fix it without recoding the whole darn thing.

In addition, this might be a bug for Mysterial, as it involves all RPG code, and not Dru's additions.

Moof, Scholar of Ni

Moof (W); Dr. Moof (M); Engimoof (E); Moofgineer (E beta)
[Yahoo!] aim icon [ICQ]
 
Forum Index -> Other Mods
Go to:   
Powered by JForum 2.1.7 © JForum Team